I agree that first one is better.

2006/7/11, Mikhail Loenko <[EMAIL PROTECTED]>:
Hi Tim

you've fixed check for parameters in one of the "(byte[], int, int)" methods
in a way different to how we fixed them before:

offset < 0 || len < 0 || (long)offset + (long)len > input.length

compare to e.g HARMONY-377 or -437:

count < 0 || offset < 0 || offset > buffer.length || count >
buffer.length - offset

Does it make sense to fix all similar methods in the same way? (I like
your fix as it's shorter)

Thanks,
Mikhail

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]




--
Alexey A. Petrenko
Intel Middleware Products Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to