[ 
https://issues.apache.org/jira/browse/HBASE-2254?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12837808#action_12837808
 ] 

Patrick Angeles commented on HBASE-2254:
----------------------------------------

Great work guys.

I'm using the maven-eclipse-plugin and this section in hbase-core/pom.xml 
prevented the plugin from adding src/main/java to the classpath:

    <resources>
      <resource>
        <directory>src/main/resources</directory>
      </resource>
      <resource>
        <directory>src/main/</directory>
        <includes>
          <include>webapps/**/*.gif</include>
          <include>webapps/**/*.css</include>
          <include>webapps/**/*.html</include>
          <include>webapps/**/*.xml</include>
        </includes>
      </resource>
    </resources>

The result .classpath file is:

... snip ...
  <classpathentry kind="src" path="src/test/java" output="target/test-classes" 
including="**/*.java"/>
  <classpathentry kind="src" path="src/test/resources" 
output="target/test-classes" excluding="**/*.java"/>
  <classpathentry kind="src" path="src/main/java" including="**/*.java"/>
  <classpathentry kind="src" path="target/jspc" including="**/*.java"/>
  <classpathentry kind="src" path="target/generated-sources" 
including="**/*.java"/>
  <classpathentry kind="src" path="src/main/resources" excluding="**/*.java"/>
  <classpathentry kind="src" path="src/main" 
including="webapps/**/*.gif|webapps/**/*.css|webapps/**/*.html|webapps/**/*.xml"
 excluding="**/*.java"/>
... snip ...

I think the latter "src/main" declaration is clobbering the prior 
"src/main/java" declaration.

Changing the POM to read:

      <resource>
        <directory>src/main/webapps</directory>
        <includes>
          <include>**/*.gif</include>
          <include>**/*.css</include>
          <include>**/*.html</include>
          <include>**/*.xml</include>
        </includes>
      </resource>

Fixes the issue.

> Improvements to the Maven POMs
> ------------------------------
>
>                 Key: HBASE-2254
>                 URL: https://issues.apache.org/jira/browse/HBASE-2254
>             Project: Hadoop HBase
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 0.21.0
>            Reporter: Lars Francke
>            Priority: Minor
>         Attachments: hbase-2254-1.patch, HBASE-2254-2.patch, 
> hbase-2254-3.patch, HBASE-2254-4.patch, HBASE-2254-5.patch, hbase2254.sh
>
>
> While the Maven build Paul Smith worked on works mostly wonderfully there are 
> a few small problems.
> * The version is set to 0.20.2-SNAPSHOT, I've changed it to 0.21.0-SNAPSHOT
> * I reformatted the poms to make them more readable. This is a file that'll 
> unfortunately be edited by humans so I hope these "whitespace only" changes 
> are acceptable
> * I've introduced the sourceEncoding property to be used instead of the 
> encoding parameters for the compiler plugins
> * I've changed the plugins section in the main pom to a pluginManagement 
> section and defined the plugin versions
> * I've fixed a type in the compiler plugin  showDeprecations -> 
> showDeprecation
> I'll continue to go over it but perhaps it already helps.
> I've done a mvn clean assembly:assembly build and everything seems to work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to