[ 
https://issues.apache.org/jira/browse/HCATALOG-191?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13185463#comment-13185463
 ] 

[email protected] commented on HCATALOG-191:
--------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/2813/#review4351
-----------------------------------------------------------



/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseInputStorageDriver.java
<https://reviews.apache.org/r/2813/#comment9797>

    need to update inputJobInfo stored in jobContext.



/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseInputStorageDriver.java
<https://reviews.apache.org/r/2813/#comment9795>

    since we're not supporting limit revision, can we set this to 1 for now?



/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HbaseSnapshotRecordReader.java
<https://reviews.apache.org/r/2813/#comment9796>

    aren't the timestamps already sorted in descending order? you don't need 
the sorting step?



/trunk/storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseInputStorageDriver.java
<https://reviews.apache.org/r/2813/#comment9799>

    use assertFalse? much more readable without equality IMHO



/trunk/storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseInputStorageDriver.java
<https://reviews.apache.org/r/2813/#comment9798>

    use equals instead?
    


- Francis


On 2012-01-03 18:07:56, Vandana Ayyalasomayajula wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/2813/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2012-01-03 18:07:56)
bq.  
bq.  
bq.  Review request for hcatalog, Francis Liu and David Capwell.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  This patch contains the general changes required in hbase storage driver 
for using revision manager. The actual integration between the read and write 
side is still to be done. 
bq.  
bq.  
bq.  This addresses bug hcatalog-191.
bq.      https://issues.apache.org/jira/browse/hcatalog-191
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    
/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseConstants.java
 1211611 
bq.    
/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseHCatStorageHandler.java
 1211611 
bq.    
/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseInputFormat.java
 1211611 
bq.    
/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseInputStorageDriver.java
 1211611 
bq.    
/trunk/storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HbaseSnapshotRecordReader.java
 PRE-CREATION 
bq.    
/trunk/storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseInputStorageDriver.java
 1211608 
bq.    
/trunk/storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestSnapshots.java
 PRE-CREATION 
bq.  
bq.  Diff: https://reviews.apache.org/r/2813/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  none. 
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Vandana
bq.  
bq.


                
> HBase input storage driver integration with zookeeper based revision manager
> ----------------------------------------------------------------------------
>
>                 Key: HCATALOG-191
>                 URL: https://issues.apache.org/jira/browse/HCATALOG-191
>             Project: HCatalog
>          Issue Type: Sub-task
>          Components: hbase
>    Affects Versions: 0.3
>            Reporter: Vandana Ayyalasomayajula
>            Assignee: Vandana Ayyalasomayajula
>            Priority: Minor
>              Labels: hbase, storage_drivers
>         Attachments: revision-mgmt-int.04.patch
>
>
> This jira deals with integration of HBase input storage driver with the 
> zookeeper based revision manager. The record reader associated with the 
> storage driver will filter record based out of the snapshot specification 
> given by the user. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to