[ 
https://issues.apache.org/jira/browse/HDFS-9255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14962246#comment-14962246
 ] 

Rakesh R commented on HDFS-9255:
--------------------------------

Thanks [~walter.k.su]. Nice work!

I've few comments, please see
# In unit tests probably you could use 
{{GenericTestUtils.assertExceptionContains}} for asserting the exception 
messages rather than swallow it.
{code}
+      try {
+        spyTask.recover();
+      } catch(IOException e){
+        // IOException: All datanodes failed
+      }
{code}
# class RecoveryTask does not need to be public. Also, how about renaming the 
class to RecoveryTaskContiguous?
# Do you have any plans to incorporate the 
[comments|https://issues.apache.org/jira/browse/HDFS-9173?focusedCommentId=14960162&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-14960162]
 discussed in HDFS-9173 here in this jira?
# Please take care the checkstyle warnings related to the patch.

> Consolidate block recovery related implementation into a single class
> ---------------------------------------------------------------------
>
>                 Key: HDFS-9255
>                 URL: https://issues.apache.org/jira/browse/HDFS-9255
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: datanode
>            Reporter: Walter Su
>            Assignee: Walter Su
>            Priority: Minor
>         Attachments: HDFS-9255.01.patch, HDFS-9255.02.patch, 
> HDFS-9255.03.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to