Rakesh R commented on HDFS-10885:

The API what we are exposing is named as isStoragePolicySatisfierActive. This 
two items would be exposed to users, So, I feel we should unify in name to 
avoid confusions.
How about naming the parameter some thing like, (option 1) 
dfs.storage.policy.satisfier.activate = true ? or to avoid Active/Standby HA 
Good point. Adding one case to consider. Say, configured 
{{dfs.namenode.sps.enabled=true}} but due to another Mover tool instance 
Namenode won't be able to start running the SPS daemon. If we name the API 
{{#isStoragePolicySatisfierEnabled}} then users may get confused that even 
after enabling, the API is returning false value, right?. IMHO, to avoid 
confusion with HA, can we rename the API to 

> [SPS]: Mover tool should not be allowed to run when Storage Policy Satisfier 
> is on
> ----------------------------------------------------------------------------------
>                 Key: HDFS-10885
>                 URL: https://issues.apache.org/jira/browse/HDFS-10885
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: datanode, namenode
>    Affects Versions: HDFS-10285
>            Reporter: Wei Zhou
>            Assignee: Wei Zhou
>             Fix For: HDFS-10285
>         Attachments: HDFS-10800-HDFS-10885-00.patch, 
> HDFS-10800-HDFS-10885-01.patch, HDFS-10800-HDFS-10885-02.patch, 
> HDFS-10885-HDFS-10285.03.patch, HDFS-10885-HDFS-10285.04.patch, 
> HDFS-10885-HDFS-10285.05.patch, HDFS-10885-HDFS-10285.06.patch, 
> HDFS-10885-HDFS-10285.07.patch, HDFS-10885-HDFS-10285.08.patch, 
> HDFS-10885-HDFS-10285.09.patch
> These two can not work at the same time to avoid conflicts and fight with 
> each other.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to