[ 
https://issues.apache.org/jira/browse/HDFS-12572?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16197736#comment-16197736
 ] 

Xiaoyu Yao commented on HDFS-12572:
-----------------------------------

Thanks [~msingh] for working on this. The patch v5 looks good to me overall. I 
just have few comments below.

LevelDBStore.java
Line 301-302: Please update javadoc to match with the behavior change
 
OzoneBucket.java
Line 534: we need to add a finally {} to ensure getRequest is closed properly.
{code}
}finally{
   OzoneClientUtils.releaseConnection(getRequest);
}
{code}
 
OzoneFileSystem.java
Line 188-196: is this optional or required for the Hadoop Compatible FS?
How do we handle path does not exist for parent and parent's parent?
E.g., client want to create /a/b/c/key1, only /a exist, both /a/b and /a/b/c 
don't
exist.
 
Line 251: rename in KSM directly will be ideal.
 
Line 277: can you elaborate the overall rename semantics supported in java doc 
with examples? 
I think it might be easier to follow if we can categorize the cases based on 
whether source/dst is
directlory or file like you did in mkdir(). 
 
Line 310: NIT: we are actually checking dst's parent not dst dir
 
Line 378: How do we handle partial delete succeed when recursive is true?
 
Line 439: NIT: returns true if directory exists or created successfully.
 
Line 680:  this can be removed as it does not provide more information than the 
trace line at 678.


> Ozone: OzoneFileSystem: delete/list status/rename/mkdir APIs
> ------------------------------------------------------------
>
>                 Key: HDFS-12572
>                 URL: https://issues.apache.org/jira/browse/HDFS-12572
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ozone
>    Affects Versions: HDFS-7240
>            Reporter: Mukul Kumar Singh
>            Assignee: Mukul Kumar Singh
>              Labels: ozoneMerge
>             Fix For: HDFS-7240
>
>         Attachments: HDFS-12572-HDFS-7240.001.patch, 
> HDFS-12572-HDFS-7240.002.patch, HDFS-12572-HDFS-7240.003.patch, 
> HDFS-12572-HDFS-7240.004.patch, HDFS-12572-HDFS-7240.005.patch
>
>
> This jira will add the delete/list status/rename/mkdir APIs



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to