[ 
https://issues.apache.org/jira/browse/HDDS-173?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16524178#comment-16524178
 ] 

Hanisha Koneru commented on HDDS-173:
-------------------------------------

Thanks for the review [~xyao]. I have addressed the comments in patch v03.
{quote} ContainerSet.java
Line 63: remove the throw StorageContainerException in the declaration.
{quote}
This StorageContainerException is caught by KeyValueHandler and returned as 
Response to the client.

{quote}KeyUtils.java
Now we have two version, one in common/helpers and one in keyvalue/helpers. Is 
it possible to consolidate to avoid duplicate code such as 
getDB/RemoveDB/shutdownCache, etc.?
{quote}
A lot of these classes will be removed when integrating the code. 
common/helpers/KeyUtils, ChunkUtils etc. will go away.

{quote}
We are passing the whole containerSet to all handlers without checking its 
supported container type. As a result, the Handler#handle() method should check 
the container#getContainerType to see if can handler the command for specific 
container type before further processing in subclass like 
KeyValueHandler#handle().
{quote}
HddsDispatcher checks the containerType and passes the request to the correct 
Handler accordingly. So KeyValueHandler will only get requests corresponding to 
containers with KeyValue as the containerType. Should we still have another 
check inside KeyValueHandler#handle()?

{quote}
Line 168: Do we have a follow up JIRA to handle out of space error and I/O 
error  in the volume layer?
{quote}
This will be added in phase 2.

> Refactor Dispatcher and implement Handler for new ContainerIO design
> --------------------------------------------------------------------
>
>                 Key: HDDS-173
>                 URL: https://issues.apache.org/jira/browse/HDDS-173
>             Project: Hadoop Distributed Data Store
>          Issue Type: Sub-task
>            Reporter: Hanisha Koneru
>            Assignee: Hanisha Koneru
>            Priority: Major
>             Fix For: 0.2.1
>
>         Attachments: HDDS-173-HDDS-48.001.patch, HDDS-173-HDDS-48.002.patch
>
>
> Dispatcher will pass the ContainerCommandRequests to the corresponding 
> Handler based on the ContainerType. Each ContainerType will have its own 
> Handler. The Handler class will process the message.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to