[ 
https://issues.apache.org/jira/browse/HDDS-317?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16589584#comment-16589584
 ] 

Anu Engineer commented on HDDS-317:
-----------------------------------

Plus, there are some minor checkStyle warnings.

 

./hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/StorageSize.java:98:
 /**: First sentence should end with a period. [JavadocStyle] 
./hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/StorageSize.java:108:
 /**: First sentence should end with a period. [JavadocStyle] 
./hadoop-hdds/container-service/src/main/java/org/apache/hadoop/ozone/container/keyvalue/KeyValueContainerData.java:219:
 
StorageSize.getStorageSizeInGB(ScmConfigKeys.OZONE_SCM_CONTAINER_SIZE_DEFAULT));:
 Line is longer than 80 characters (found 88). [LineLength] 
./hadoop-hdds/server-scm/src/main/java/org/apache/hadoop/hdds/scm/block/BlockManagerImpl.java:34:import
 org.apache.hadoop.ozone.OzoneConsts;:8: Unused import - 
org.apache.hadoop.ozone.OzoneConsts. [UnusedImports] 
./hadoop-hdds/server-scm/src/main/java/org/apache/hadoop/hdds/scm/container/ContainerStateManager.java:39:import
 org.apache.hadoop.ozone.OzoneConsts;:8: Unused import - 
org.apache.hadoop.ozone.OzoneConsts. [UnusedImports] 
./hadoop-hdds/server-scm/src/main/java/org/apache/hadoop/hdds/scm/pipelines/PipelineSelector.java:42:import
 org.apache.hadoop.ozone.OzoneConsts;:8: Unused import - 
org.apache.hadoop.ozone.OzoneConsts. [UnusedImports] 
./hadoop-hdds/server-scm/src/test/java/org/apache/hadoop/hdds/scm/container/closer/TestContainerCloser.java:75:
 size = 
StorageSize.getStorageSizeInByte(configuration.get(OZONE_SCM_CONTAINER_SIZE,: 
Line is longer than 80 characters (found 87). [LineLength]

> Use new StorageSize API for reading ozone.scm.container.size.gb
> ---------------------------------------------------------------
>
>                 Key: HDDS-317
>                 URL: https://issues.apache.org/jira/browse/HDDS-317
>             Project: Hadoop Distributed Data Store
>          Issue Type: Improvement
>          Components: SCM
>            Reporter: Nanda kumar
>            Assignee: Junjie Chen
>            Priority: Major
>              Labels: newbie
>             Fix For: 0.2.1
>
>         Attachments: HDDS-317.2.patch, HDDS-317.patch
>
>
> Container size is configured using property {{ozone.scm.container.size.gb}}. 
> This can be renamed to {{ozone.scm.container.size}} and use new StorageSize 
> API to read the value.
> The property is defined in
>  1. ozone-default.xml
>  2. ScmConfigKeys#OZONE_SCM_CONTAINER_SIZE_GB
> The default value is defined in
>  1. ozone-default.xml
>  2. {{ScmConfigKeys#OZONE_SCM_CONTAINER_SIZE_DEFAULT}}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]

Reply via email to