[
https://issues.apache.org/jira/browse/HDFS-3503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13951653#comment-13951653
]
Tsz Wo Nicholas Sze commented on HDFS-3503:
-------------------------------------------
[~cmccabe], thanks. PositionTrackingInputStream is well written. Nice work!
"Tracking" seems unnecessary. I will rename it to PositionInputStream.
The abstraction of StreamLimiter may not be useful in general. I will combine
it with PositionInputStream.
> Move LengthInputStream and PositionTrackingInputStream to common
> ----------------------------------------------------------------
>
> Key: HDFS-3503
> URL: https://issues.apache.org/jira/browse/HDFS-3503
> Project: Hadoop HDFS
> Issue Type: Improvement
> Reporter: Tsz Wo Nicholas Sze
> Assignee: Tsz Wo Nicholas Sze
> Priority: Minor
>
> We have LengthInputStream in org.apache.hadoop.hdfs.server.datanode.fsdataset
> and PositionTrackingInputStream in
> org.apache.hadoop.hdfs.server.namenode.FSEditLogLoader. These two classes
> are generally useful. Let's move them to org.apache.hadoop.io.
--
This message was sent by Atlassian JIRA
(v6.2#6252)