[
https://issues.apache.org/jira/browse/HDFS-3503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13962454#comment-13962454
]
Hadoop QA commented on HDFS-3503:
---------------------------------
{color:red}-1 overall{color}. Here are the results of testing the latest
attachment
http://issues.apache.org/jira/secure/attachment/12639073/h3503_20140407.patch
against trunk revision .
{color:green}+1 @author{color}. The patch does not contain any @author
tags.
{color:green}+1 tests included{color}. The patch appears to include 3 new
or modified test files.
{color:green}+1 javac{color}. The applied patch does not increase the
total number of javac compiler warnings.
{color:green}+1 javadoc{color}. There were no new javadoc warning messages.
{color:green}+1 eclipse:eclipse{color}. The patch built with
eclipse:eclipse.
{color:green}+1 findbugs{color}. The patch does not introduce any new
Findbugs (version 1.3.9) warnings.
{color:green}+1 release audit{color}. The applied patch does not increase
the total number of release audit warnings.
{color:red}-1 core tests{color}. The test build failed in
hadoop-hdfs-project/hadoop-hdfs/src/contrib/bkjournal
{color:green}+1 contrib tests{color}. The patch passed contrib unit tests.
Test results:
https://builds.apache.org/job/PreCommit-HDFS-Build/6608//testReport/
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/6608//console
This message is automatically generated.
> Move LengthInputStream and PositionTrackingInputStream to common
> ----------------------------------------------------------------
>
> Key: HDFS-3503
> URL: https://issues.apache.org/jira/browse/HDFS-3503
> Project: Hadoop HDFS
> Issue Type: Improvement
> Reporter: Tsz Wo Nicholas Sze
> Assignee: Tsz Wo Nicholas Sze
> Priority: Minor
> Attachments: h3503_20140328.patch, h3503_20140407.patch
>
>
> We have LengthInputStream in org.apache.hadoop.hdfs.server.datanode.fsdataset
> and PositionTrackingInputStream in
> org.apache.hadoop.hdfs.server.namenode.FSEditLogLoader. These two classes
> are generally useful. Let's move them to org.apache.hadoop.io.
--
This message was sent by Atlassian JIRA
(v6.2#6252)