On Tue, Oct 18, 2016 at 12:48 PM, rishat <ris...@nixnotes.ru> wrote:
> Hi Andrei
> May I ask another question? How I can debug this behaviour? I believe that
> BIOS initializes this adapter. Need to say that "PnP OS" was setted to "Yes"
> value. I've changed it to "No" and ... same silence in the minicom.

Well, assuming BIOS did initialize this card it may use different port
address. The one you see in setserial output is assigned by Linux
driver. I do not know how flexible it is, but I presume they may

Try lspci command in GRUB. Does it show your card at all? It also
displays some details of current card setup.

You may want to use "set pager=1" otherwise output will scroll too fast.

If you see your card could you send screenshot of information GRUB shows?

> Then I
> pulled out this adapter and inserted this pci serial adapter to the other PC
> computer. It has already integrated COM port, this one is working fine, I
> have tried to do serial connection via pci adapter, but again I've got
> nothing. I just want to figure out is this something I can do with
> motherboard or my pci adapter is not compatible. If I need to change this
> card do you have list of pci, pci-e card that successfully can by used? Is
> it possible I've faced to situation when two motherboards can't initialize
> this hardware?
> Thank you in advance.
> --
> Best regards
> Rishat
> On 2016-10-18 06:47, Andrei Borzenkov wrote:
>> 17.10.2016 22:22, Songatov Rishat пишет:
>>> Hi thank you for helping me!
>>> Unfortunately I haven't got serial access to the grub after adding this
>>> piece of configuration:
>>> insmod pci
>>> insmod serial
>>> insmod terminal
>>> insmod terminfo
>>> ###serial --speed=115200 --port=a880 --word=8 --parity=no --stop=1
>>> serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1
>>> terminal_input serial
>>> terminal_output serial
>>> May be I need some sleep time after inserting pci.mod. How I can do this?
>> You can pause with "sleep NN" but as I already wrote this is not likely
>> to work anyway - either GRUB needs code to initialize your PCI card or
>> BIOS should do it. Try BIOS settings, in the past it was common to have
>> something like "PnP OS" where "no" would cause BIOS to initialize all
>> available hardware and "yes" would leave it to operating system.
>>> --
>>> Best regards
>>> Rishat
>>> On 17.10.2016 20:34, Andrei Borzenkov wrote:
>>>> 17.10.2016 19:41, rishat пишет:
>>>>> On 2016-10-17 19:16, Andrei Borzenkov wrote:
>>>>>> 17.10.2016 16:16, rishat пишет:
>>>>>>> setserial -g /dev/ttyS[0-4]
>>>>>>> /dev/ttyS0, UART: 16550A, Port: 0xa880, IRQ: 21
>>>>>> ...
>>>>>>> When I tried to manually type a "serial --speed=115200 --unit=0
>>>>>>> --word=8
>>>>>>> --parity=no --stop=1" in the grub command line it complains that COM1
>>>>>>> port don't exist. I have played with unit and port attributes but
>>>>>>> without any luck.
>>>>>> Does "serial --port=a880 ..." work? If not, what exactly happens?
>>>>>> Note that you may need to load at least PCI bus driver (insmod pci)
>>>>>> for
>>>>>> this to work.
>>>>> I've tried to use it that way but it didn't find com port again.
>>>>> I'll try to do insmod pci and write to you tomorrow.
>>>> Yes, please let us know, but on firther consideration it probably won't
>>>> help either. Card likely needs to be initialized first, and this
>>>> requires driver that knows how to do it. serial driver in GRUB presumes
>>>> hardware is in working state already. Someone would need to implement
>>>> it.
>>>>> By the way is it possible to share documentation about some useful
>>>>> modules in the grub? I havn't found any information using google.
>>>>>> _______________________________________________
>>>>>> Help-grub mailing list
>>>>>> Help-grub@gnu.org
>>>>>> https://lists.gnu.org/mailman/listinfo/help-grub

Help-grub mailing list

Reply via email to