Sorry to forgot to provide it, i will attach it as soon i'm back of traveling 
(~1 march).

In the meantime i tried to compile it with "guix environment guix --ad-hoc" 
with partially success because i hit 2 bug

First one : ( could be skip from what i read )


Second one:


So, even if we solved my problem, i will still encounter those bugs and the 
second one is problematic from my point of view because it seems than the 
builds can't be done without to be root.

Best regards,


De : Chris Marusich <cmmarus...@gmail.com>
Envoyé : mercredi 21 février 2018 06:44
Cc : help-guix@gnu.org
Objet : Re: Building guix from source with --prefix=$HOME/.local 

YOANN P <yoann_mac_don...@hotmail.com> writes:

> Hi guix,
> I've tried many times to build guix from source to fully install it inside my 
> ~/.local but without success and don't get why.
> You could find my installation script partially based on Pjotrp recipes 
> here<https://pastebin.co
> system reconfigure") m/vNY0cM4x> and the full log here<htt
> system reconfigure") ps://pastebin.com/fNdK9hva>.
> "make" seems ok
> "make check" fail
> "./pre-inst-env guix-daemon" fail with "guix-daemon: error while loading 
> shared libraries: libz.so.1: cannot open shared object file: No such file or 
> directory"
> Did i miss something ?
> How to have guix fully installed inside ~/.local with a datastore inside 
> ~/.local/gnu/store and not related to the guix installed on the system ?
> Thanks,
> Best regards,

If you could attach the test-suite.log file, it might be helpful.


Reply via email to