On 06/04/2018 10:40, Chris Wilson wrote:
Quoting Tvrtko Ursulin (2018-04-06 10:11:57)


On 30/03/2018 14:18, Chris Wilson wrote:
                       if (!wait_for_hang(&h, prev)) {

This was confusing me a period since I was assuming the seqno check is
against the breadcrumb, but it is actually about the same number written
to a different place. So it actually means
wait_for_request_to_start_executing.

Bonus points for a better name than struct hang.

struct spinner;

spinner_wait_until_active() ?

Maybe just rename the helper to wait_until_running if you feel like it. To keep things simple and scope in check.

Regards,

Tvrtko
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to