Use the macro to improve readability.

Signed-off-by: Cezary Rojewski <cezary.rojew...@intel.com>
---
 sound/pci/hda/hda_codec.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sound/pci/hda/hda_codec.c b/sound/pci/hda/hda_codec.c
index 12f02cdc9659..2cac337f5263 100644
--- a/sound/pci/hda/hda_codec.c
+++ b/sound/pci/hda/hda_codec.c
@@ -3313,7 +3313,7 @@ int snd_hda_codec_parse_pcms(struct hda_codec *codec)
        list_for_each_entry(cpcm, &codec->pcm_list_head, list) {
                int stream;
 
-               for (stream = 0; stream < 2; stream++) {
+               for_each_pcm_streams(stream) {
                        struct hda_pcm_stream *info = &cpcm->stream[stream];
 
                        if (!info->substreams)
-- 
2.25.1

Reply via email to