From: Ville Syrjälä <[email protected]>
Clean up some of the mess in the bw/sagv code.
Ville Syrjälä (11):
drm/i915/bw: Don't memcpy() pointlessly
drm/i915/bw: Streamline dg2_get_bw_info()
drm/i915/bw: Initialize num_planes sensibly for the first plane group
in TGL+
drm/i915/bw: Move 'bi_next' to tighter scope
drn/i915/bw: s/num_points/num_qgv_points/
drm/i915/bw: Move num_{qgv,psf}_points out from the plane group
drm/i915/bw: Move psf_bw[] out from the plane group
drm/i915/bw: Move peakbw[] out from the plane group
drm/i915/bw: Print derated bandwidth numbers for DG2
drm/i915/bw: Use icl_qgv_bw()
drm/i915/bw: Simplify the best max_data_rate search
drivers/gpu/drm/i915/display/intel_bw.c | 168 ++++++++----------
.../gpu/drm/i915/display/intel_display_core.h | 12 +-
2 files changed, 82 insertions(+), 98 deletions(-)
--
2.53.0