Compared to previous version, fix the stolen oops and create
and use xe_ggtt_reserve_area instead of xe_ggtt_insert_node_at.
Reserve the original GGTT area of the original mapping, and remove
the code that was required to deal with the fact that previously
this was not done.
Maarten Lankhorst (6):
drm/xe/ggtt: Add xe_ggtt_reserve_area
drm/xe/ggtt: Add xe_ggtt_node_remove_noclear
drm/xe/display: Reserve the original GGTT space before creating a bo
drm/xe/display: Use the correct calculation for phys_base on
integrated
drm/xe/display: Remove duplicated code
drm/xe/ggtt: Remove xe_ggtt_insert_bo_at
drivers/gpu/drm/xe/display/xe_initial_plane.c | 41 +++----
drivers/gpu/drm/xe/xe_bo.c | 8 +-
drivers/gpu/drm/xe/xe_ggtt.c | 115 ++++++++++++++----
drivers/gpu/drm/xe/xe_ggtt.h | 5 +-
4 files changed, 110 insertions(+), 59 deletions(-)
--
2.53.0