On 18 September 2013 14:50, Sean Coates <s...@seancoates.com> wrote:
> i.e. is_null($a, $b, $c) would be the same as is_null($a) && is_null($b)
> && is_null($c)
>
> Note that this would not be semantically equivalent in this form, even if
> `is_null()` did accept multiple parameters, because of the short-circuiting
> with `&&`:

See below.

On 18 September 2013 15:53, Patrick ALLAERT <patrickalla...@php.net> wrote:
> 2013/9/18 Chris London <m...@chrislondon.co>:
>> I like the naming convention of are_*.  For me personally it isn't directly
>> intuitive that the multiple parameters of is_* would be compared with an &&
>> and not an ||.
>
> isset() already operates that way, keeping "is_" and implementing it
> as originally proposed by Leigh would, at least, be consistent.

Indeed, my proposal was to mimic short circuiting as isset() does it,
evaluating LTR and returning false at the earliest opportunity.

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to