Attached are the patches that will fix issues where iPXE fails in 1Gbps mode 
when APE (management firmware) is disabled.  Brandon and others have confirmed 
that these patches fixed their problems.  

-----Original Message-----
From: Kevin Tran 
Sent: Monday, October 08, 2012 3:28 PM
To: 'Brandon Penglase';
Subject: RE: [ipxe-devel] Recent tg3 driver commits still fail on gigabit

Hi Brandon,
We were able to reproduce the issue you reported on BCM5764m.  We already 
resolved this.   I will send you the fixes on other e-mail.  Once you confirm 
that your issue is fixed, we will submit the changes.

-----Original Message-----
From: Brandon Penglase []
Sent: Wednesday, August 22, 2012 10:57 AM
Cc: Kevin Tran
Subject: Re: [ipxe-devel] Recent tg3 driver commits still fail on gigabit

        Thanks for getting back to us.
        It seems the only b57diag I've been able to find is from 2004 (or 
earlier). The download I'm finding on the website is for b57udiag, which 
doesn't seem to have the -b57eng option.
        When I use the one from 2004, I get "Invalid device 0 requested."
        I don't believe there is any sort of management on this machine that 
would be involved. It's a Dell FX160, BIOS A07. It does have the ImageServer 
option, but it is not currently enabled. According to the b57udiag -dir it 
0 5764M:B0 02:00:0 Ex1 250 FEBF 10 128k/128k 00262d21e4ec 5764m-v3.35 W

        If it helps, I only have the problem when booting with a ipxe.usb thats 
been DD'd to a 2gb thumb drive. I haven't tried a CD yet, but using the built 
in UNDI to chainload to iPXE ends up working fine. I have used two different 
gigabit switches, the original was a 16port Linksys one, the current is a 8port 
Netgear GS108.

        Brandon Penglase

Kevin Tran ktran at
Tue Aug 21 23:49:47 BST 2012

Hi Brandon,

I tested iPXE with BCM5764m and it works fine for me even with 1G port 
on the Dell 6224 switch.   I didn't test out all possible device 
configurations yet.  We mainly focused our testing on BCM5719 devices.

Your problem might be due to the fact that management firmware is 
enabled on the your setup .   I need to reproduce your problem in my 
environment and I need the configuration of your NIC.

1. Enter engineering mode

     B57diag -b57eng

2. log mycfg.txt

3. dev

4. dir

5. secfg

6. press <enter> a few times and then type cancel.

7. close

All the configuration will be captured in the mycfg.txt.  Send me the file 



-----Original Message-----
From: Brandon Penglase [mailto:bpenglase-ipxe at]
Sent: Tuesday, August 21, 2012 8:25 AM
To: ipxe-devel at
Cc: Brendon Walsh; Kevin Tran
Subject: Re: [ipxe-devel] Recent tg3 driver commits still fail on gigabit

Should have added this one too: , where we had 
actually worked on it in the IRC Channel.

Brandon Penglase

On 08/21/12 11:15, Brandon Penglase wrote:

 > I noticed this, this morning as well. I plan to do some debugging this

 > afternoon, once I get some other issues out of the way from the start

 > of our semester.

 > I'm not sure if Kevin has seen the previous post or not, but it's

 > here: .


 > I do want to thank the guys/gals at Broadcom who are putting an effort

 > into this, as it does appear to have fixed a different issue we had

 > (If you booted via USB, into a WinPE image, the WinPE image was not

 > able to use the NIC. This appears to be working as expected now).


 > I plan to do a DEBUG=tg3 build, so if more debugging, or another is

 > requested, let me know and I can include that. The machine I have for

 > testing does have a Serial output, so I can easily grab any console

 > output.


 > Brandon Penglase



 > On 08/21/12 10:53, Brendon Walsh wrote:

 >> Hi,


 >> I just wanted to notify everyone that the recent commit with fixes

 >> for the tg3 driver (a05871d89ad9b94248049c66f238092fc896e9aa) have

 >> not made any noticeable difference in regards to functionality on

 >> gigabit interfaces.


 >> I am testing with BCM5764M and while iPXE will function properly on

 >> 100Mbit, it fails on DHCP still on a gigabit link. This behaviour is

 >> the same as before this commit.


 >> Thanks Kevin and all others who are working on this. I can provide

 >> any data that may help with resolving this issue.


 >> Brendon



 >> _______________________________________________

 >> ipxe-devel mailing list

 >> ipxe-devel at<mailto:ipxe-devel at>




 > _______________________________________________

 > ipxe-devel mailing list

 > ipxe-devel at<mailto:ipxe-devel at>



Attachment: tg3_hw.c.patch
Description: tg3_hw.c.patch

Attachment: tg3.patch
Description: tg3.patch

ipxe-devel mailing list

Reply via email to