Tomo Suzuki created BEAM-8876:
---------------------------------

             Summary: Tests to confirm Hadoop version compatibility
                 Key: BEAM-8876
                 URL: https://issues.apache.org/jira/browse/BEAM-8876
             Project: Beam
          Issue Type: Test
          Components: build-system
            Reporter: Tomo Suzuki


Add test(s) to confirm Hadoop version compatibility for hadoop_client library 
version against different users' environment.

https://github.com/apache/beam/pull/10222#issuecomment-559158067

[~iemejia] had an idea:

{quote}After a quick review most of the major users and systems still support 
2.7 and ‘even worse’ 2.6. So I was wondering how can we ensure that new patches 
on Hadoop modules don’t break backwards compatibility.

One idea could be to add an extra set of tests that run the build for the 
provided previous versions of the dependencies. But I don’t have a clue how to 
do this in gradle. Do you by any chance? (Note that a fix for this will solve 
other compatibility issues we have with other systems and provided dependencies 
e.g. Spark and Kafka). {quote}







--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to