[
https://issues.apache.org/jira/browse/CALCITE-4224?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17193430#comment-17193430
]
Julian Hyde commented on CALCITE-4224:
--------------------------------------
Looks good. I might add 'This method is intended mainly for use while debugging
code in an IDE, as a convenient short-hand for RelOptUtil.toString. We
recommend that sub-classes do not override this method'.
Your point about 'final' not combining with 'default' makes sense.
Does anyone has an idea for a better name than 'tree'?
> Add a method for RelNode to output its tree digest like RelOptUtil.toString
> ---------------------------------------------------------------------------
>
> Key: CALCITE-4224
> URL: https://issues.apache.org/jira/browse/CALCITE-4224
> Project: Calcite
> Issue Type: Improvement
> Components: core
> Reporter: Jiatao Tao
> Assignee: Jiatao Tao
> Priority: Minor
> Labels: pull-request-available
> Time Spent: 1h 10m
> Remaining Estimate: 0h
>
--
This message was sent by Atlassian Jira
(v8.3.4#803005)