[ 
https://issues.apache.org/jira/browse/FLINK-7284?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16115337#comment-16115337
 ] 

mingleizhang commented on FLINK-7284:
-------------------------------------

Hi, [~till.rohrmann] I would like work on this, but before start working. I 
have some things need to confirm with you.

1. How can I get runtime version of hadoop ? I think 
{{VersionInfo.getVersion()}} should be a correct way to get it.

2. How can I get compile time or called build time version of hadoop ? you said 
it has to be included in the Flink binaries, hmm. I think I should confirm it. 
I found there is a file called {{flink-conf.yaml}}. Do I need to add a key like 
called {{hadoop.version}} in this file? and when loading configuration property 
as cluster start up, then I can get this value.

3. After geting these two value, check x==y or x!=y.

4. Done.

Thanks, Minglei

> Verify compile time and runtime version of Hadoop
> -------------------------------------------------
>
>                 Key: FLINK-7284
>                 URL: https://issues.apache.org/jira/browse/FLINK-7284
>             Project: Flink
>          Issue Type: Improvement
>          Components: Cluster Management
>    Affects Versions: 1.4.0
>            Reporter: Till Rohrmann
>
> In order to detect a potential version conflict when running a Flink cluster, 
> built with Hadoop {{x}}, in an environment which provides Hadoop {{y}}, we 
> should automatically check if {{x == y}}. If {{x != y}}, we should terminate 
> with an appropriate error message. This behaviour should also be 
> disengageable if one wants to run Flink explicitly in a different Hadoop 
> environment.
> The check could be done at cluster start up using Hadoops {{VersionInfo}} and 
> the build time Hadoop version info. The latter has to be included in the 
> Flink binaries.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to