mingleizhang commented on FLINK-8824:

Hi, [~StephanEwen] The only problematic seems I can get like the following. 
Other than that, I think all good.

//inner class

Will print as follows

java.util.AbstractMap$SimpleEntry // correct way
java.util.AbstractMap.SimpleEntry // wrong way


> In Kafka Consumers, replace 'getCanonicalName()' with 'getClassName()'
> ----------------------------------------------------------------------
>                 Key: FLINK-8824
>                 URL: https://issues.apache.org/jira/browse/FLINK-8824
>             Project: Flink
>          Issue Type: Bug
>          Components: Kafka Connector
>            Reporter: Stephan Ewen
>            Assignee: mingleizhang
>            Priority: Major
>             Fix For: 1.5.0
> The connector uses {{getCanonicalName()}} in all places, gather than 
> {{getClassName()}}.
> {{getCanonicalName()}}'s intention is to normalize class names for arrays, 
> etc, but is problematic when instantiating classes from class names.

This message was sent by Atlassian JIRA

Reply via email to