Stephan Ewen commented on FLINK-8824:

You are right, nested classes are the problematic case. Arrays and primitive 
types do not make sense in these places anyways.

This one case (nested classes) is a good reason to fix this. Plus we set the 
right example for how to do things for future contributors.

> In Kafka Consumers, replace 'getCanonicalName()' with 'getClassName()'
> ----------------------------------------------------------------------
>                 Key: FLINK-8824
>                 URL: https://issues.apache.org/jira/browse/FLINK-8824
>             Project: Flink
>          Issue Type: Bug
>          Components: Kafka Connector
>            Reporter: Stephan Ewen
>            Assignee: mingleizhang
>            Priority: Major
>             Fix For: 1.5.0
> The connector uses {{getCanonicalName()}} inĀ all places, gather than 
> {{getClassName()}}.
> {{getCanonicalName()}}'s intention is to normalize class names for arrays, 
> etc, but is problematic when instantiating classes from class names.

This message was sent by Atlassian JIRA

Reply via email to