Github user tillrohrmann commented on a diff in the pull request:
    --- Diff: 
    @@ -75,12 +75,12 @@ private ReadOnlySlicedNetworkBuffer(ByteBuf buffer, int 
index, int length, int m
        public ByteBuf unwrap() {
    -           return super.unwrap().unwrap();
    +           return super.unwrap();
    --- End diff --
    But isn't it a bit counter-intuitive that you instantiate a 
`ReadOnlySlicedNetworkBuffer` with a `NetworkBuffer` and when you call 
`ReadOnlySlicedNetworkBuffer.unwrap` you don't get a `NetworkBuffer` back but a 
`SlicedByteBuf`? Thus, you need to know the internals of this class to know 
that you have to call twice `unwrap` to obtain the `NetworkBuffer`. This shows 
for example in the `NetworkBufferTest` where we always call 
    What exactly did change with the structure of nested classes that this 
change is necessary?


Reply via email to