[ 
https://issues.apache.org/jira/browse/FLINK-4824?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15571879#comment-15571879
 ] 

Maximilian Michels commented on FLINK-4824:
-------------------------------------------

That was recently changed (before we would simply get a NullPointerException 
due to missing plan information). See FLINK-4677.

{quote}
I think the error message is misleading, because I tried executing a valid 
Flink job.
{quote}

Actually your jar did not generate a valid Flink job. It is capable of creating 
one but how should the CliFrontend know? :) 

> CliFrontend shows misleading error message when main() method returns before 
> env.execute()
> ------------------------------------------------------------------------------------------
>
>                 Key: FLINK-4824
>                 URL: https://issues.apache.org/jira/browse/FLINK-4824
>             Project: Flink
>          Issue Type: Bug
>          Components: Client
>    Affects Versions: 1.2.0
>            Reporter: Robert Metzger
>
> While testing Flink by running the 
> {{./examples/streaming/SocketWindowWordCount.jar}} example, I got the 
> following error message:
> {code}
> ./bin/flink run ./examples/streaming/SocketWindowWordCount.jar 
> Cluster configuration: Standalone cluster with JobManager at /127.0.0.1:6123
> Using address 127.0.0.1:6123 to connect to JobManager.
> JobManager web interface address http://127.0.0.1:8081
> Starting execution of program
> No port specified. Please run 'SocketWindowWordCount --port <port>', where 
> port is the address of the text server
> To start a simple text server, run 'netcat -l <port>' and type the input text 
> into the command line
> ------------------------------------------------------------
>  The program finished with the following exception:
> org.apache.flink.client.program.ProgramInvocationException: The program 
> didn't contain Flink jobs. Perhaps you forgot to call execute() on the 
> execution environment.
>       at 
> org.apache.flink.client.program.ClusterClient.run(ClusterClient.java:324)
>       at 
> org.apache.flink.client.CliFrontend.executeProgram(CliFrontend.java:774)
>       at org.apache.flink.client.CliFrontend.run(CliFrontend.java:250)
>       at 
> org.apache.flink.client.CliFrontend.parseParameters(CliFrontend.java:985)
>       at org.apache.flink.client.CliFrontend$2.run(CliFrontend.java:1032)
>       at org.apache.flink.client.CliFrontend$2.run(CliFrontend.java:1029)
>       at 
> org.apache.flink.runtime.security.SecurityContext$1.run(SecurityContext.java:82)
>       at java.security.AccessController.doPrivileged(Native Method)
>       at javax.security.auth.Subject.doAs(Subject.java:422)
>       at 
> org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1548)
>       at 
> org.apache.flink.runtime.security.SecurityContext.runSecured(SecurityContext.java:79)
>       at org.apache.flink.client.CliFrontend.main(CliFrontend.java:1029)
> {code}
> I think the error message is misleading, because I tried executing a valid 
> Flink job.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to