ASF GitHub Bot commented on FLINK-3999:

Github user StephanEwen commented on the issue:

    I am a bit skeptical about these types of changes.
    Maintaining stability of Flink is crucially important now. With changes 
like these we risk introducing subtle bugs without fixing a bug or improving a 
functionality or anything. It just changes a naming preference.
    The kind of bugs one can introduce with changes like that are very subtle 
(we have seen that in cases where the cancelling logic was fragile depending on 
how the flag was exactly set) and hard to catch all in reviews. Not everything 
is fully covered by bullet proof tested in practice.
    I would actually suggest to rather contribute on issues where there is a 
clearer benefit.

> Rename the `running` flag in the drivers to `canceled`
> ------------------------------------------------------
>                 Key: FLINK-3999
>                 URL: https://issues.apache.org/jira/browse/FLINK-3999
>             Project: Flink
>          Issue Type: Bug
>          Components: Local Runtime
>            Reporter: Gabor Gevay
>            Assignee: Neelesh Srinivas Salian
>            Priority: Trivial
> The name of the {{running}} flag in the drivers doesn't reflect its usage: 
> when the operator just stops normally, then it is not running anymore, but 
> the {{running}}  flag will still be true, since the {{running}} flag is only 
> set when cancelling.
> It should be renamed, and the value inverted.

This message was sent by Atlassian JIRA

Reply via email to