[
https://issues.apache.org/jira/browse/GEODE-3385?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16154171#comment-16154171
]
ASF subversion and git services commented on GEODE-3385:
--------------------------------------------------------
Commit 501bd79a8bc161649df4e3113c27b0093faab45d in geode's branch
refs/heads/develop from [~WireBaron]
[ https://gitbox.apache.org/repos/asf?p=geode.git;h=501bd79 ]
GEODE-3385: Change GetAllRequest to return list of errors.
Also:
* Rename `KeyedErrorResponse` to `KeyedError`.
* move `ErrorResponse` to `clientProtocol.proto`.
* Check for null `value` in `ProtobufUtilities.createEntry`.
If we find a null, we don't set the value; previously this resulted in
NPE.
Signed-off-by: Galen O'Sullivan <[email protected]>
> Change GetAllRequest to return list of errors
> ---------------------------------------------
>
> Key: GEODE-3385
> URL: https://issues.apache.org/jira/browse/GEODE-3385
> Project: Geode
> Issue Type: Sub-task
> Components: client/server
> Reporter: Galen O'Sullivan
> Assignee: Galen O'Sullivan
>
> GetAllRequest currently returns a list of successful keys or an error (if
> getting any key threw an exception). We should instead return a list of
> errors, similar to PutAllRequest.
--
This message was sent by Atlassian JIRA
(v6.4.14#64029)