[ 
https://issues.apache.org/jira/browse/GEODE-3584?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16310097#comment-16310097
 ] 

Kenneth Howe commented on GEODE-3584:
-------------------------------------

Thanks for your input. If you haven't reviewed the Apache Geode wiki yet I'd 
start here (can answer some basic questions on running tests and using an IDE): 
https://cwiki.apache.org/confluence/display/GEODE/Getting+Started+for+Geode+Developers

Regarding your original questions:
2. For measuring test coverage I would strongly suggest using the Eclipse or 
Intellij for your development environment. Both IDEs offer coverage 
tools/plugins. You can then run, run with coverage, or debug entire test 
classes or single tests within a class directly through the IDE. For running 
with coverage, the covered code is then highlighted in the IDE editor pane.

3. In general several smaller patches (pull requests) are preferred. You are 
likely to have fewer merge conflicts with other ongoing work with small 
localized PRs.

4. For running a few test classes I would run them individually in the IDE. For 
running more than a few you could run them from a shell using the gradlew 
command for running single tests as shown in the Wiki page I referenced. For 
instance to run the tests {{AbstractLauncherIntegrationTest}}, 
{{LocatorLauncherIntegrationTest}}, and {{ServerLauncherIntegrationTest}} your 
shell commands would be 
{{code}}
./gradlew -DintegrationTest.single=AbstractLauncherIntegrationTest 
integrationTest
./gradlew -DintegrationTest.single=LocatorLauncherIntegrationTest 
integrationTest
./gradlew -DintegrationTest.single=ServerLauncherIntegrationTest integrationTest
{{code}}

For the {{testType}} look at the Category annotation in the test class 
declaration.


> Refactor ServerLauncher and LocatorLauncher to eliminate code duplication
> -------------------------------------------------------------------------
>
>                 Key: GEODE-3584
>                 URL: https://issues.apache.org/jira/browse/GEODE-3584
>             Project: Geode
>          Issue Type: Improvement
>          Components: gfsh
>    Affects Versions: 1.2.0
>            Reporter: Kenneth Howe
>
> There is some duplication of code in the Launcher classes that can be 
> eliminated. Both classes have methods such as getBindAddress (called 
> getServerBindAddress in ServerLauncher) that could be hoisted into  
> AbstractLauncher class that they both extend. The same goes for the inner 
> State classes of the Launchers; they have methods that could be moved to 
> AbstractLauncher.ServiceState.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to