Jens Deppe created GEODE-6351:
---------------------------------
Summary: CI failure:
WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient.testSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient
fails with bind exception
Key: GEODE-6351
URL: https://issues.apache.org/jira/browse/GEODE-6351
Project: Geode
Issue Type: Test
Components: tests
Reporter: Jens Deppe
This test failed with a port bind exception. Looks like
AvailablePort.getRandomAvailablePort returned the same port twice in a row.
{code:java}
[vm0_v160, 0xe86a47a5] [info 2019/01/31 18:59:23.340 UTC <RMI TCP
Connection(1)-172.17.0.39> tid=0x23] Locator started on 172.17.0.39[23232]
[vm0_v160, 0xe86a47a5] [info 2019/01/31 18:59:23.341 UTC <RMI TCP
Connection(1)-172.17.0.39> tid=0x23] Starting server location for Distribution
Locator on f36bf775c28c[23232] [vm0_v160, 0xe86a47a5] [info 2019/01/31
18:59:23.372 UTC <RMI TCP Connection(1)-172.17.0.39> tid=0x23] Got result: null
[vm0_v160, 0xe86a47a5] from
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$137/0x0000000840191840.run
with 0 args on object:
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$137/0x0000000840191840@666db70c
(took 3573 ms) [vm0_v160, 0xe86a47a5] [info 2019/01/31 18:59:23.383 UTC <RMI
TCP Connection(1)-172.17.0.39> tid=0x23] Received method:
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$212/0x00000008403ba440.run
with 0 args on object:
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$212/0x00000008403ba440@4fb85825
[vm0_v160, 0xe86a47a5] [info 2019/01/31 18:59:23.390 UTC <WAN Locator
Discovery Thread> tid=0x59] Locator discovery task exchanged locator
information f36bf775c28c[23232] with f36bf775c28c[23232]:
{0=[f36bf775c28c[23232]]}. [vm0_v160, 0xe86a47a5] [info 2019/01/31 18:59:23.511
UTC <RMI TCP Connection(1)-172.17.0.39> tid=0x23] Got result: null [vm0_v160,
0xe86a47a5] from
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$212/0x00000008403ba440.run
with 0 args on object:
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$212/0x00000008403ba440@4fb85825
(took 127 ms) [vm4, 0x11b043a5] [info 2019/01/31 18:59:23.514 UTC <RMI TCP
Connection(4)-172.17.0.39> tid=0x22] Received method:
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$129/0x00000008401a4c40.run
with 0 args on object:
org.apache.geode.cache.wan.WANRollingUpgradeSecondaryEventsNotReprocessedAfterCurrentSiteMemberFailoverWithOldClient$$Lambda$129/0x00000008401a4c40@76a7e7a3
[vm4, 0x11b043a5] [info 2019/01/31 18:59:23.518 UTC <RMI TCP
Connection(4)-172.17.0.39> tid=0x22] Starting peer location for Distribution
Locator on f36bf775c28c[23232] [vm4, 0x11b043a5] [info 2019/01/31 18:59:23.518
UTC <RMI TCP Connection(4)-172.17.0.39> tid=0x22] Starting Distribution Locator
on f36bf775c28c[23232] [vm4, 0x11b043a5] [info 2019/01/31 18:59:23.529 UTC <RMI
TCP Connection(4)-172.17.0.39> tid=0x22] Got result: EXCEPTION_OCCURRED [vm4,
0x11b043a5] java.net.BindException: Failed to create server socket on
f36bf775c28c/172.17.0.39[23232]{code}
Notice that vm4_160 uses port 23232 and then right away the next locator to
start also wants to use that port.
Test results are here:
http://files.apachegeode-ci.info/builds/apache-develop-main/1.9.0-SNAPSHOT.0392/test-results/upgradeTest/1548962442/
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)