[ 
https://issues.apache.org/jira/browse/HBASE-8465?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13822016#comment-13822016
 ] 

Ted Yu commented on HBASE-8465:
-------------------------------

{code}
+      failSafeSnapshotSnapshotName = 
conf.get("hbase.snapshot.restore.failsafe.name",
+        "hbase-restore-failsafe-{table.name}-{restore.timestamp}");
{code}
The failsafe snapshot name is pretty long. Can it include the snapshotName for 
the restore operation ?
{code}
+          String msg = "Restore snapshot=" + snapshotName +
+            " failed. Rollback to snapshot=" + failSafeSnapshotSnapshotName + 
" succeeded.";
+          LOG.error(msg, e);
+          internalRestoreSnapshot(failSafeSnapshotSnapshotName, tableName);
{code}
The success message seems to come a bit early.

> Auto-drop rollback snapshot for snapshot restore
> ------------------------------------------------
>
>                 Key: HBASE-8465
>                 URL: https://issues.apache.org/jira/browse/HBASE-8465
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Ted Yu
>            Assignee: Ted Yu
>             Fix For: 0.98.0, 0.96.1
>
>         Attachments: 8465-trunk-v1.txt, 8465-trunk-v2.txt, HBASE-8465-v3.patch
>
>
> Below is an excerpt from snapshot restore javadoc:
> {code}
>    * Restore the specified snapshot on the original table. (The table must be 
> disabled)
>    * Before restoring the table, a new snapshot with the current table state 
> is created.
>    * In case of failure, the table will be rolled back to the its original 
> state.
> {code}
> We can improve the handling of rollbackSnapshot in two ways:
> 1. give better name to the rollbackSnapshot (adding 
> {code}'-for-rollback-'{code}). Currently the name is of the form:
>     String rollbackSnapshot = snapshotName + "-" + 
> EnvironmentEdgeManager.currentTimeMillis();
> 2. drop rollbackSnapshot at the end of restoreSnapshot() if the restore is 
> successful. We can introduce new config param, named 
> 'hbase.snapshot.restore.drop.rollback', to keep compatibility with current 
> behavior.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Reply via email to