[
https://issues.apache.org/jira/browse/HBASE-4190?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13082764#comment-13082764
]
[email protected] commented on HBASE-4190:
------------------------------------------------------
bq. On 2011-08-10 23:29:27, Andrew Purtell wrote:
bq. > src/main/java/org/apache/hadoop/hbase/HConstants.java, line 500
bq. > <https://reviews.apache.org/r/1461/diff/1/?file=31956#file31956line500>
bq. >
bq. > CP_ATTR_KEY_PATTERN for clarity.
Or CP_HTD_ATTR_KEY_PATTERN would be even clearer.
bq. On 2011-08-10 23:29:27, Andrew Purtell wrote:
bq. > src/main/java/org/apache/hadoop/hbase/HConstants.java, line 502
bq. > <https://reviews.apache.org/r/1461/diff/1/?file=31956#file31956line502>
bq. >
bq. > CP_ATTR_VALUE_PATTERN for clarity.
Or CP_HTD_ATTR_VALUE_PATTERN would be even clearer.
- Andrew
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/1461/#review1401
-----------------------------------------------------------
On 2011-08-10 23:23:03, Mingjie Lai wrote:
bq.
bq. -----------------------------------------------------------
bq. This is an automatically generated e-mail. To reply, visit:
bq. https://reviews.apache.org/r/1461/
bq. -----------------------------------------------------------
bq.
bq. (Updated 2011-08-10 23:23:03)
bq.
bq.
bq. Review request for hbase.
bq.
bq.
bq. Summary
bq. -------
bq.
bq. Coprocessors: pull up some cp constants from cp package to
o.a.h.h.HConstants
bq.
bq.
bq. This addresses bug HBASE-4190.
bq. https://issues.apache.org/jira/browse/HBASE-4190
bq.
bq.
bq. Diffs
bq. -----
bq.
bq. src/main/java/org/apache/hadoop/hbase/HConstants.java dda254d
bq. src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java d835582
bq.
src/main/java/org/apache/hadoop/hbase/regionserver/RegionCoprocessorHost.java
c44da73
bq.
bq. Diff: https://reviews.apache.org/r/1461/diff
bq.
bq.
bq. Testing
bq. -------
bq.
bq. TestClassLoading passed locally.
bq.
bq.
bq. Thanks,
bq.
bq. Mingjie
bq.
bq.
> Coprocessors: pull up some cp constants from cp package to o.a.h.h.HConstants
> -----------------------------------------------------------------------------
>
> Key: HBASE-4190
> URL: https://issues.apache.org/jira/browse/HBASE-4190
> Project: HBase
> Issue Type: Improvement
> Components: coprocessors
> Affects Versions: 0.90.4
> Reporter: Mingjie Lai
> Assignee: Mingjie Lai
> Priority: Minor
> Fix For: 0.90.5
>
>
> At HBase-3810, stack gave a comment after patch committed:
> > This is a bit odd where a class in the parent package has references to a
> > sub package.
> > Should these classes or at least their constants be pulled up to be at same
> > level as HTableD?
> Create a new jira where the constants will be pulled from
> o.a.h.h.regionserver.RegionCoprocessorHost to o.a.h.h.HConstants.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira