[ 
https://issues.apache.org/jira/browse/HBASE-11826?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14118240#comment-14118240
 ] 

Carter commented on HBASE-11826:
--------------------------------

[~stack] listed a preference above to keep the deprecated methods.  Can the 
crew please give me guidance, and I'll be happy to remove or leave in, as 
desired.  I can appreciate both sides of the argument, so I'm somewhat 
ambivalent.

> Split each tableOrRegionName admin methods into two targetted methods
> ---------------------------------------------------------------------
>
>                 Key: HBASE-11826
>                 URL: https://issues.apache.org/jira/browse/HBASE-11826
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Carter
>            Assignee: Carter
>         Attachments: HBASE_11826.patch, HBASE_11826_v2.patch, 
> HBASE_11826_v2.patch
>
>
> Purpose of this is two implement [~enis]'s suggestion to strongly type the 
> methods that take "tableOrRegionName" as an argument.
> For instance:
> {code}
> void compact(final String tableNameOrRegionName)
> void compact(final byte[] tableNameOrRegionName)
> {code}
> becomes
> {code}
> @Deprecated
> void compact(final String tableNameOrRegionName)
> @Deprecated
> void compact(final byte[] tableNameOrRegionName)
> void compact(TableName table)
> void compactRegion(final byte[] regionName)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to