[ 
https://issues.apache.org/jira/browse/HBASE-12161?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14159816#comment-14159816
 ] 

Dima Spivak commented on HBASE-12161:
-------------------------------------

Thanks for taking this on, Srikanth. Some minor suggestions:

- Your method declaration for getAccessControlServiceStub should be split over 
two lines. Same for the AccessControlClient.grant in 
#testAccessControlClientGrantOnNameSpace.
- The AccessControlClient#grant and #revoke methods have nearly identical logic 
that might as well be factored into a common private method to avoid a bit of 
code duplication.
- Similarly (as you explained to me), your 
#testAccessControlClientGrantOnNameSpace is very similar to the existing 
#testNamespaceUserGrant. It might be worth factoring out the common bits and 
only leaving the different grant methods used by each test.
- In #testAccessControlClientGrantOnNameSpace, you handle a Throwable by just 
logging it which swallow any exception that might break things. Is this 
intentional or might you want the test to fail at this point if such a general 
exception is thrown?

> Add support for grant/revoke on namespaces in AccessControlClient
> -----------------------------------------------------------------
>
>                 Key: HBASE-12161
>                 URL: https://issues.apache.org/jira/browse/HBASE-12161
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Srikanth Srungarapu
>            Assignee: Srikanth Srungarapu
>            Priority: Minor
>         Attachments: HBASE-12161_0.98.patch
>
>
> As per the description.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to