[ 
https://issues.apache.org/jira/browse/HBASE-13346?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16174489#comment-16174489
 ] 

Anoop Sam John commented on HBASE-13346:
----------------------------------------

Filter.java 
Why new filterCell method missing from here?!  We need add here
No need to do any extra things for filterKeyValue in FilterBase (than what we 
may have today)
FilterList#filterKeyValue() - This calls filterKeyValue() on individual 
filters.  This also we have to change.. Within our code base, we have to call 
the new method only. The default impl of the new method has to call the old 
method (This has to be done in Filter base class).  This is for BC for custom 
filters.  Users even have directly extended Filter class. That is why we have 
to add there only with a def impl (We are on JDK 1.8+)
Import
Filter.ReturnCode code = filter.filterKeyValue(c);
Change here also to filterCell?  Any way the def impl would be calling old 
method and if the Import is having new code (new jar) Filter class also would 
be new.

> Clean up Filter package for post 1.0 s/KeyValue/Cell/g
> ------------------------------------------------------
>
>                 Key: HBASE-13346
>                 URL: https://issues.apache.org/jira/browse/HBASE-13346
>             Project: HBase
>          Issue Type: Bug
>          Components: API, Filters
>    Affects Versions: 2.0.0
>            Reporter: Lars George
>            Assignee: Tamas Penzes
>            Priority: Critical
>             Fix For: 2.0.0-alpha-4
>
>         Attachments: HBASE-13346.master.001.patch, 
> HBASE-13346.master.002.patch, HBASE-13346.master.003.patch, 
> HBASE-13346.master.003.patch
>
>
> Since we have a bit of a messy Filter API with KeyValue vs Cell reference 
> mixed up all over the place, I recommend cleaning this up once and for all. 
> There should be no {{KeyValue}} (or {{kv}}, {{kvs}} etc.) in any method or 
> parameter name.
> This includes deprecating and renaming filters too, for example 
> {{FirstKeyOnlyFilter}}, which really should be named {{FirstKeyValueFilter}} 
> as it does _not_ just return the key, but the entire cell. It should be 
> deprecated and renamed to {{FirstCellFilter}} (or {{FirstColumnFilter}} if 
> you prefer).
> In general we should clarify and settle on {{KeyValue}} vs {{Cell}} vs 
> {{Column}} in our naming. The latter two are the only ones going forward with 
> the public API, and are used synonymous. We should carefully check which is 
> better suited (is it really a specific cell, or the newest cell, aka the 
> newest column value) and settle on a naming schema.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to