[ 
https://issues.apache.org/jira/browse/HBASE-13120?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sean Busbey updated HBASE-13120:
--------------------------------
    Component/s:     (was: hbase)
                 scripts
                 hadoop2

> Allow disabling hadoop classpath and native library lookup
> ----------------------------------------------------------
>
>                 Key: HBASE-13120
>                 URL: https://issues.apache.org/jira/browse/HBASE-13120
>             Project: HBase
>          Issue Type: Improvement
>          Components: hadoop2, scripts
>    Affects Versions: 0.98.0
>            Reporter: Siddharth Wagle
>            Priority: Major
>             Fix For: 1.0.1, 1.1.0, 0.98.12, 2.0.0
>
>         Attachments: HBASE-13120-1.patch, HBASE-13120.patch
>
>
> - Current bin/hbase script sets the java.library.path to include hadoop 
> native libs based on what version of hadoop is installed on the box.
> {code}
> HADOOP_IN_PATH=$(PATH="${HADOOP_HOME:-${HADOOP_PREFIX}}/bin:$PATH" which 
> hadoop 2>/dev/null)
> {code}
> - This effectively means that a self-contained HBase running with a different 
> version of embedded hadoop jars will fail to work in case of version 
> incompatibilities.
> - Example: AMBARI-5707, runs a embedded HBase on local FS side-by-side with 
> cluster Hadoop installation.
> - It would be good to have a hbase-env variable to completely override native 
> lib path or a config to disable native lib path lookup, in which case user 
> has to provide it during start.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to