Alan Gates commented on HIVE-19164:

I do not believe this is an issue with metastore changes.  The config file 
being handed to the HiveMetaStore.getMSForConf has schema verification set to 
true.  However, the config file being handed to Driver in 
TestMetastoreVersion.testMetastoreVersion has it set to false.  This means the 
driver is somewhere not passing the config file it is handed down to 
HiveMetaStore.  I notice as well that this test passes if run in isolation, so 
I'm guessing that somewhere the Driver or Hive (the class) isn't cleaning up an 
old config and is reusing it.

> TestMetastoreVersion failures
> -----------------------------
>                 Key: HIVE-19164
>                 URL: https://issues.apache.org/jira/browse/HIVE-19164
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Test
>            Reporter: Vineet Garg
>            Assignee: Alan Gates
>            Priority: Major
>             Fix For: 3.0.0
> Following tests are failing consistently and are reproducible on master:
> * testVersionMatching
> * testMetastoreVersion
> I tried debugging it and found that ObjectStore.getMSSchemaVersion() throws 
> an exception {{No matching version found}}. 
> To fetch schema version this method executes {code:sql} SELECT FROM 
> org.apache.hadoop.hive.metastore.model.MVersionTable {code} but for whatever 
> reason execution returns empty result set resulting in the exception. Both 
> test failures are due to this exception. I tried debugging the query 
> execution but didn't really go nowhere with it. I suspect this could be due 
> to recent metastore changes. I tried reproducing this outside test but with 
> no success.

This message was sent by Atlassian JIRA

Reply via email to