Ashutosh Chauhan commented on HIVE-19164:

Since this is failing only in test not outside, I don't see a reason to change 
Hive.java to propagate HiveConf. [~vihangk1] Would you like to upload your 
patch so that we get QA run on it?

> TestMetastoreVersion failures
> -----------------------------
>                 Key: HIVE-19164
>                 URL: https://issues.apache.org/jira/browse/HIVE-19164
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Test
>            Reporter: Vineet Garg
>            Assignee: Alan Gates
>            Priority: Major
>             Fix For: 3.0.0
>         Attachments: HIVE-19164.patch
> Following tests are failing consistently and are reproducible on master:
> * testVersionMatching
> * testMetastoreVersion
> I tried debugging it and found that ObjectStore.getMSSchemaVersion() throws 
> an exception {{No matching version found}}. 
> To fetch schema version this method executes {code:sql} SELECT FROM 
> org.apache.hadoop.hive.metastore.model.MVersionTable {code} but for whatever 
> reason execution returns empty result set resulting in the exception. Both 
> test failures are due to this exception. I tried debugging the query 
> execution but didn't really go nowhere with it. I suspect this could be due 
> to recent metastore changes. I tried reproducing this outside test but with 
> no success.

This message was sent by Atlassian JIRA

Reply via email to