Sahil Takiar commented on HIVE-19212:

[~pvary] lets try this again :)

It looks like when I was testing HIVE-18883 I had forgotten that I had added 
the {{--dirty-workspace}} parameter, which was why FindBugs was working locally.

The attached patch reverts the changes to {{dev-support/yetus-wrapper.sh}} done 
in HIVE-18883. Instead, I just manually installed the FindBugs package on the 
ptest-master. {{yetus-exec.vm}} just sets {{FINDBUGS_HOME}} to the location of 
the package.

I'm not a huge fan of this approach because if the ptest-master dies FindBugs 
will stop working unless someone remembers to re-install the FindBugs package. 
However, I couldn't find a better way to do this. At first I tried to add some 
code to install FindBugs in {{yetus-exec.vm}} if it isn't already installed, 
but that won't work because the {{hiveptest}} and {{tomcat}} users on the 
ptest-master don't have permissions to install packages via {{apt-get}}.

I'm hoping that if we move to the Docker based Yetus execution this will get 
cleaned up.

> Fix findbugs yetus pre-commit checks
> ------------------------------------
>                 Key: HIVE-19212
>                 URL: https://issues.apache.org/jira/browse/HIVE-19212
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Testing Infrastructure
>            Reporter: Sahil Takiar
>            Assignee: Sahil Takiar
>            Priority: Major
>         Attachments: HIVE-19212.1.patch
> Follow up from HIVE-18883, the committed patch isn't working and Findbugs is 
> still not working.

This message was sent by Atlassian JIRA

Reply via email to