[ 
https://issues.apache.org/jira/browse/IGNITE-5052?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16012015#comment-16012015
 ] 

Vladimir Ozerov commented on IGNITE-5052:
-----------------------------------------

[~al.psc], my comments:
1) {{IgniteQueryErrorCode.QUERY_ENTITIES_PRESENT}} - let's remove this error 
code
2) {{IgniteKernal.getOrCreateCache0}} - code duplication; looks like we should 
call {{getOrCreateCache0()}} from {{getOrCreateCache()}} to avoid it;
3) {{GridSqlCreateTable}} - please remove {{getSql()}} body, as it is not used
4) {{GridSqlQueryParser}} - unused imports and static constants
5) {{DdlStatementsProcessor.toQueryEntity}} - {{_KEY}} and {{_VAL}} columns 
should raise {{PARSING}} exception, they are already agnostic to caches; also 
it looks like all these checks should be moved to parser, so that successfull 
parsing mean that we have valid model (you already did that for NOT NULL 
columns and extra params)
6) {{IgniteH2Indexing.dynamicTableCreate}} - call to {{ctx.cache().cache()}} at 
the verŠ½ beginning is wrong; see 
{{org.apache.ignite.internal.IgniteKernal#createCache(java.lang.String)}} and 
{{org.apache.ignite.internal.processors.cache.GridCacheProcessor#createConfigFromTemplate}}
 on how to get configuration for template
7) {{IgniteH2Indexing.dynamicTableDrop}} - let's avoid call to 
{{space(schemaName)}} as this method will be removed soon to allow for multiple 
tables from different caches in the same schema
8) {{IgniteH2Indexing}} - both {{dynamicTableCreate}} and {{dynamicTableDrop}} 
methods do not have anything H2-specific; we should remove it from H2, and move 
relevant code to {{GridQueryProcessor}}
9) {{GridQueryProcessor}} - no wildcards in imports
10) {{GridCacheProcessor}} - I would ask [~agoncharuk] or [~sboikov] to review 
this change

> Implement CREATE/DROP TABLE parsing and execution
> -------------------------------------------------
>
>                 Key: IGNITE-5052
>                 URL: https://issues.apache.org/jira/browse/IGNITE-5052
>             Project: Ignite
>          Issue Type: Task
>          Components: sql
>            Reporter: Vladimir Ozerov
>            Assignee: Alexander Paschenko
>              Labels: important
>             Fix For: 2.1
>
>
> Convert SQL string to relevant Igntie command. This could be:
> - {{createCache}}
> - {{getOrCreateCache}} (for {{IF NOT EXISTS}} case)
> - {{destroyCache}}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to