[ 
https://issues.apache.org/jira/browse/KARAF-5300?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16121336#comment-16121336
 ] 

ASF subversion and git services commented on KARAF-5300:
--------------------------------------------------------

Commit be4a73b8e7c3815c7b4923e723ca1c53575085df in karaf's branch 
refs/heads/model_features from [~ch...@die-schneider.net]
[ https://git-wip-us.apache.org/repos/asf?p=karaf.git;h=be4a73b ]

[KARAF-5300] Add documentation


> FeaturesService should use more specific classes for model
> ----------------------------------------------------------
>
>                 Key: KARAF-5300
>                 URL: https://issues.apache.org/jira/browse/KARAF-5300
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>
> Currently the feature service uses strings for many different purposes:
> - feature name
> - feature name glob
> - feature version
> - feature version range
> It is difficult to tell what purpose such a string has.
> I would like to create a type FeatureReq(name, VersionRange) that describes 
> better what we do. This should make the code a lot easier to understand.
> Ideally we would also reflect this in the service interface but the stay 
> backwards compatbile I will only use the new types internally.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to