[
https://issues.apache.org/jira/browse/MWAR-356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15147182#comment-15147182
]
Alberto Mozzone edited comment on MWAR-356 at 2/15/16 10:44 AM:
----------------------------------------------------------------
I tested your proposed solution and it works as I want: thanks a lot!
Just a question: do you think that using "src/main/webapp/WEB-INF/classes"
instead of "src/main/webresources" is a good practice, or should I create a
separate folder (as you did)?
{code:xml}
<webResources>
<resource>
<directory>src/main/webapp/WEB-INF/classes</directory>
<filtering>true</filtering>
<targetPath>WEB-INF/classes</targetPath>
</resource>
</webResources>
{code}
Please note that this setup works just as yours.
Edit:
Just to add that, with the said solutions, the generated JARs differ in name
only, while content and MD5 are the same.
was (Author: alberto.mozzone):
I tested your proposed solution and it works as I want: thanks a lot!
Just a question: do you think that using "src/main/webapp/WEB-INF/classes"
instead of "src/main/webresources" is a good practice, or should I create a
separate folder (as you did)?
{code:xml}
<webResources>
<resource>
<directory>src/main/webapp/WEB-INF/classes</directory>
<filtering>true</filtering>
<targetPath>WEB-INF/classes</targetPath>
</resource>
</webResources>
{code}
Please note that this setup works just as yours.
> "archiveClasses" and "attachClasses" should archive/attach classes only
> -----------------------------------------------------------------------
>
> Key: MWAR-356
> URL: https://issues.apache.org/jira/browse/MWAR-356
> Project: Maven WAR Plugin
> Issue Type: Improvement
> Affects Versions: 2.6
> Reporter: Alberto Mozzone
> Fix For: waiting-for-feedback
>
> Attachments: mwar-356-test.zip
>
>
> As their name implies, "archiveClasses" and "attachClasses" should avoid to
> put in the resulting jar the files under "src/main/resources" because:
> # they're not classes
> # they should be left in "WEB-INF/classes"
> # they could be environment dependent: via filtering, the resources in the
> deployed artifact could contain information which simply do not make sense in
> the repository (or, worse, could contain sensitive information)
> Of course, to preserve backward compatibility, I just suggest 2 alternatives:
> # a brand new element which joins the behavior of "archiveClasses" and
> "attachClasses" (e. g. "packageClasses/deployClasses") and a sibling element
> "packageResources" which puts the resources in a jar file in "WEB-INF/lib",
> but not in the repo
> # a new option used by the two elements which activates the new behavior.
> I'm assuming that the properties in subject should behave the same to avoid
> differences in artifact naming or content; see also
> [MWAR-215|https://issues.apache.org/jira/browse/MWAR-215].
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)