[ 
https://issues.apache.org/jira/browse/MWAR-356?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Alberto Mozzone updated MWAR-356:
---------------------------------
    Comment: was deleted

(was: Just to add that, with the said solutions, the generated JARs differ in 
name only, while content and MD5 are the same.)

> "archiveClasses" and "attachClasses" should archive/attach classes only
> -----------------------------------------------------------------------
>
>                 Key: MWAR-356
>                 URL: https://issues.apache.org/jira/browse/MWAR-356
>             Project: Maven WAR Plugin
>          Issue Type: Improvement
>    Affects Versions: 2.6
>            Reporter: Alberto Mozzone
>             Fix For: waiting-for-feedback
>
>         Attachments: mwar-356-test.zip
>
>
> As their name implies, "archiveClasses" and "attachClasses" should avoid to 
> put in the resulting jar the files under "src/main/resources" because:
> # they're not classes
> # they should be left in "WEB-INF/classes"
> # they could be environment dependent: via filtering, the resources in the 
> deployed artifact could contain information which simply do not make sense in 
> the repository (or, worse, could contain sensitive information)
> Of course, to preserve backward compatibility, I just suggest 2 alternatives:
> # a brand new element which joins the behavior of "archiveClasses" and 
> "attachClasses" (e. g. "packageClasses/deployClasses") and a sibling element 
> "packageResources" which puts the resources in a jar file in "WEB-INF/lib", 
> but not in the repo
> # a new option used by the two elements which activates the new behavior.
> I'm assuming that the properties in subject should behave the same to avoid 
> differences in artifact naming or content; see also 
> [MWAR-215|https://issues.apache.org/jira/browse/MWAR-215].



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to