[
https://issues.apache.org/jira/browse/SOLR-15701?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17431374#comment-17431374
]
Chris M. Hostetter commented on SOLR-15701:
-------------------------------------------
It seems like there are at least 2 (maybe 3 counting docs) independent things
that are being discussed & addressed her that can/should be tackled discretely
because they don't particularly need to be tied together (ie: we can commit
them independently) ...
# Adding SolrJ support for the existing server side "UPLOAD" API
** can be done ASAP, no backcompat risks, fills an important functionality gap
for solrj users
# Maybe better documentation about how the _existing_ solr APIs (and their
SolrJ client code) can be used to create (either by upload or by clone/copy) /
modify / replace configsets
** Ie: rename & expand the various sections of the ref-guide page to be more
"Action" specific (Create, Clone, Update, etc...) and then in each section
identify which API to use drawing attention to some of the API oddities (Create
-> UPLOAD, Clone -> CREATE, Update -> UPLOAD w/overwrite, etc...)
** can be done ASAP, no backcompat risks
# "fix" how the existing server (& SolrJ) API works so that they make more
sense from a CRUD perspective
** ie: rename CREATE to CLONE ? ... replace UPLOAD w/ CREATE and UPDATE ?
** and while we're at it: why does CREATE (aka "clone") currently support
{{configSetProp.*}} but UPLOAD doesn't?
** has lots of backcompat complexity
** has lots of v1 vs v2 API complexity
I feel like we should go ahead and create subtasks for #1 and #3 to track &
discuss these discretely ...
* get #1 out the door ASAP (it's pretty straight forward)
* if #3 seems like it's not something we have a clear vision for in the short
term, then create a subtask for #2 to document the oddness quickly.
> ConfigSet SolrJ API is incomplete
> ---------------------------------
>
> Key: SOLR-15701
> URL: https://issues.apache.org/jira/browse/SOLR-15701
> Project: Solr
> Issue Type: Bug
> Components: configset-api
> Affects Versions: 8.10
> Reporter: Andrzej Bialecki
> Assignee: Andrzej Bialecki
> Priority: Major
>
> SolrJ ConfigSet API allows users to manage configsets but it's curiously
> incomplete (and somewhat misleading):
> * CREATE action doesn't actually allow users to create a wholly new
> configset, it only allows to copy one of the existing configsets under a new
> name. It should really be renamed to COPY.
> * there's no support for UPLOAD action in the SolrJ API, which is a strange
> omission - there's support for every other action but there's no (easy) way
> to upload a new configset. {{ConfigSetHandler}} supports this action so the
> problem lies only in the missing client classes.
> I'll work on adding support for UPLOAD, but I'm not sure what to do with the
> mis-named CREATE - I'd love to rename it but this would cause back-compat
> issues. Maybe deprecate it, rename it only in 9.0 and keep supporting CREATE
> -> COPY until 9.1 release?
--
This message was sent by Atlassian Jira
(v8.3.4#803005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]