[ 
https://issues.apache.org/jira/browse/TEZ-1897?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14518254#comment-14518254
 ] 

Bikas Saha commented on TEZ-1897:
---------------------------------

bq. Rename registerAndCreateDispatcher to registerAndCreateConcurrentDispatcher 
?
bq. Rename registerWithExistingDispatcher to 
registerWithExistingConcurrentDispatcher ?
The types in the arguments should be enough to differentiate and also provide 
compile time check. Adding it to the names would be redundant. Also, once this 
code is exercised and stabilized then we may use this as the only dispatcher.

bq. Javadoc for AsyncDispatcherConcurrent is the same as AsyncDispatcher
Fixed

bq. Precondition numThreads should be at least 2 ? I think 1 is the same as 
AysnDispatcher
This should be able to replace the legacy AsyncDispatcher and run all events on 
a single thread in the threadpool. So its allowed.

bq. TaskAttemptImpl.java Some places still use getTask().getVertex(), can 
change to getVertex directly.
Fixed


> Create a concurrent version of AsyncDispatcher
> ----------------------------------------------
>
>                 Key: TEZ-1897
>                 URL: https://issues.apache.org/jira/browse/TEZ-1897
>             Project: Apache Tez
>          Issue Type: Task
>            Reporter: Bikas Saha
>            Assignee: Bikas Saha
>         Attachments: TEZ-1897.1.patch, TEZ-1897.2.patch, TEZ-1897.3.patch, 
> TEZ-1897.4.patch, TEZ-1897.5.patch, TEZ-1897.6.patch
>
>
> Currently, it processes events on a single thread. For events that can be 
> executed in parallel, e.g. vertex manager events, allowing higher concurrency 
> may be beneficial.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to