Today I restarted Jabberd2 and it's supporting daemons, for the first time in a long while. I was no longer able to log in -- TLS negotiation with the LDAP server was failing. All my configuration files are version controlled and I was not able to find any changes in between now and the last time I started Jabberd2; however, I poked around for more than an hour -- tried more configuration options, verbose logging on the LDAP server, setting all permissions to 777, rebuilding Jabberd2 -- nothing worked.
Finally I rebuilt Jabberd2 with debugging, removed c2s from `jabberd.cfg`, restarted it and then ran `c2s` in debugging mode, as root. Everything worked! So now what? I added `c2s` as back to `jabberd.cfg` and it promptly failed to connect to the LDAP server again. I'm not really sure what I need to do to debug this problem. Were it a permissions issue, I have no idea what it could be permission of -- examining the results of `lsof`, I can't see anything that `c2s` is opening that it needs to root to access. Please let me know if you have any ideas about this, or if you have encountered this problem yourself. -- _jsn -- To unsubscribe send a mail to [EMAIL PROTECTED]
