Branch: refs/heads/next
Home: https://github.com/siemens/jailhouse
Commit: ee6b86704d892c94969b636f01361fbcb6e1ebaf
https://github.com/siemens/jailhouse/commit/ee6b86704d892c94969b636f01361fbcb6e1ebaf
Author: Andreas Kölbl <[email protected]>
Date: 2016-10-28 (Fri, 28 Oct 2016)
Changed paths:
R hypervisor/arch/arm-common/dbg-write-pl011.c
A hypervisor/arch/arm-common/uart-pl011.c
M hypervisor/arch/arm/Makefile
A hypervisor/arch/arm/include/asm/uart-pl011.h
R hypervisor/arch/arm/include/asm/uart_pl011.h
M inmates/lib/arm/uart-pl011.c
Log Message:
-----------
arm: Rename uart_pl011.h to uart-pl011.h and dbg-write-pl011.c to uart-pl011.c
Makes naming consistent.
Signed-off-by: Andreas Kölbl <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>
Commit: 4ff272bd69b35161acf3dae416bc1fab623f8750
https://github.com/siemens/jailhouse/commit/4ff272bd69b35161acf3dae416bc1fab623f8750
Author: Andreas Kölbl <[email protected]>
Date: 2016-10-28 (Fri, 28 Oct 2016)
Changed paths:
M hypervisor/arch/arm-common/dbg-write.c
R hypervisor/arch/arm/include/asm/debug.h
M hypervisor/arch/arm/include/asm/uart-8250-dw.h
M hypervisor/arch/arm/include/asm/uart-pl011.h
M hypervisor/arch/arm/include/asm/uart-tegra.h
A hypervisor/arch/arm/include/asm/uart.h
M inmates/lib/arm/printk.c
Log Message:
-----------
arm: Rename debug.h to uart.h
This header is only included by concrete uart drivers. Furthermore, it
only declares the the abstract uart_chip structure. Naming it debug.h
might be misleading.
Signed-off-by: Andreas Kölbl <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>
Commit: 29e850a17e0e2647c635d56f6c5a322abbd30962
https://github.com/siemens/jailhouse/commit/29e850a17e0e2647c635d56f6c5a322abbd30962
Author: Andreas Kölbl <[email protected]>
Date: 2016-10-28 (Fri, 28 Oct 2016)
Changed paths:
M hypervisor/arch/x86/dbg-write.c
M inmates/demos/x86/32-bit-demo.c
M inmates/demos/x86/apic-demo.c
M inmates/demos/x86/e1000-demo.c
M inmates/demos/x86/ioapic-demo.c
M inmates/demos/x86/pci-demo.c
M inmates/demos/x86/smp-demo.c
M inmates/demos/x86/tiny-demo.c
M inmates/lib/x86/printk.c
Log Message:
-----------
arm: Rename CONFIG_UART_OXPCIE952 to CONFIG_SERIAL_OXPCIE952
All configuration parameters for serial drivers are prefixed by CONFIF_UART_*,
except of OXPCIE952. In order to get consistency, CONFIG_UART_OXPCIE952 should
be renamed to CONFIG_SERIAL_OXPCIE952
Signed-off-by: Andreas Kölbl <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>
Commit: b9c2261182cce1bba6192810b753b48dcb31c4f9
https://github.com/siemens/jailhouse/commit/b9c2261182cce1bba6192810b753b48dcb31c4f9
Author: Andreas Kölbl <[email protected]>
Date: 2016-10-28 (Fri, 28 Oct 2016)
Changed paths:
M hypervisor/arch/arm/Makefile
A hypervisor/arch/arm/smp-stubs.c
R hypervisor/arch/arm/smp.c
Log Message:
-----------
arm: rename smp.c to smp-stubs.c
Add the suffix -stubs to smp.c to make it more obvious that the file
only contains stubs. Use a consistent naming for stubs (cf. cat-stubs).
Signed-off-by: Andreas Kölbl <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>
Commit: c54a34a292d425adc60f9c6860529db2ef94344b
https://github.com/siemens/jailhouse/commit/c54a34a292d425adc60f9c6860529db2ef94344b
Author: Vitaly Andrianov <[email protected]>
Date: 2016-10-29 (Sat, 29 Oct 2016)
Changed paths:
M inmates/lib/arm/gic-v2.c
Log Message:
-----------
inmates: arm: lib: fix gic_enable() to enable SPI interrupts
The gic_enable() of gic v2 can enable only first 32 interrupts.
This commit allows to enable other interrupts as well.
Signed-off-by: Vitaly Andrianov <[email protected]>
Signed-off-by: Jan Kiszka <[email protected]>
Compare:
https://github.com/siemens/jailhouse/compare/9fa7af71856e...c54a34a292d4
--
You received this message because you are subscribed to the Google Groups
"Jailhouse" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
For more options, visit https://groups.google.com/d/optout.