I am creating a lib for Microchip's 23k256 SRAM (costs about $1) similar to 24LC256 EEPROM but much much faster (up to 20MHz) and uses SPI bus instead of I2C (spi mode_00)
http://www.microchip.com/wwwproducts/Devices.aspx?dDocName=en539039 What should I name the variables & procedures since I cannot use numbers as first characters in procedures & vars. eg: 23k256_init() is const byte 23K256_READ = 0b_0000_0011 -- Read data from memory array beginning at selected address const byte 23K256_WRITE = 0b_0000_0010 -- Write data to memory array beginning at selected address const byte 23K256_READ_STATUS = 0b_0000_0101 -- Read status register const byte 23K256_WRITE_SETTINGS = 0b_0000_0001 -- Write settings register I'm an SPI kind of guy :o) Matt. --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "jallib" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/jallib?hl=en -~----------~----~----~----~------~----~------~--~---
