Hi Matt,

I'd recommend you choose a 3.3 volt picmicro, rather than trying to
interface 3.3v parts to a 5 volt picmicro.  It could be done, but why
put yourself thru all of the hassle?

About switching modes -- we may never find a generic solution for
that, since there are so many chips out there, and they don't all
quite behave the same way. Take a look at this web page, where this
type of problem is being discussed (he calls it multi-slave
configuration)  http://elm-chan.org/docs/mmc/mmc_e.html

I expect many projects will just have to use our JAL SPI library as a
starting point for their own, custom, version of the library.  It is
unfortunate, but sometimes the most practical solution.  We're only
talking about a hand-full of lines of code anyway.

William


On Oct 29, 12:47 pm, mattschinkel <[email protected]> wrote:
> What is the correct way to interface a 5v PIC input/output to a 3.3v
> component? Asuming the pin will change from input to output throughout
> the program.
>
> I will make a tutorial for this chip but need a correct circuit.
> Currently I am using 47nf cap parellel to a 4.7kohm resistor direct
> from pin to pin.
>
> Matt.
>
> On Oct 28, 5:43 am, William <[email protected]> wrote:
>
>
>
> > Hi Matt,
>
> > Nice to hear from you!
>
> > How about "sr23_" for prefix to the names?   And I suppose you'll put
> > the library under include/storage/sram/sr23k256.jal ?
>
> > Take care: that is a lower-voltage part (not 5 volt tolerant), and
> > you'll need a battery if you want persistent storage.  Many picmicros
> > will operate at lower voltages, but sometimes only at a reduced
> > frequency. Also some older ICSP flash-burners will not work at the
> > lower voltages.  The ICD2 is fine, and I'm sure many others are also.
>
> > William
>
> > On Oct 28, 2:26 am, mattschinkel <[email protected]> wrote:
>
> > > I am creating a lib for Microchip's 23k256 SRAM (costs about $1)
>
> > > similar to 24LC256 EEPROM but much much faster (up to 20MHz) and uses
> > > SPI bus instead of I2C (spi mode_00)
>
> > >http://www.microchip.com/wwwproducts/Devices.aspx?dDocName=en539039
>
> > > What should I name the variables & procedures since I cannot use
> > > numbers as first characters in procedures & vars.
>
> > > eg:
>
> > > 23k256_init() is
>
> > > const byte 23K256_READ  = 0b_0000_0011   -- Read data from memory
> > > array beginning at selected address
> > > const byte 23K256_WRITE = 0b_0000_0010  -- Write data to memory array
> > > beginning at selected address
> > > const byte 23K256_READ_STATUS  = 0b_0000_0101   -- Read status
> > > register
> > > const byte 23K256_WRITE_SETTINGS  = 0b_0000_0001   -- Write settings
> > > register
>
> > > I'm an SPI kind of guy :o)
> > > Matt.- Hide quoted text -
>
> > - Show quoted text -
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"jallib" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to 
[email protected]
For more options, visit this group at 
http://groups.google.com/group/jallib?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to