Seb, Please have a look at my changes, let me know what you think. I
am fairly happy about API except that there are many things to rename.

Maybe we can start by changing everything from "lcd" to "glcd". I'll
read through everything carefully and give you a list of things I
think could be renamed. Maybe you can do the same?

I did some changes to allow block writes, the user has an option:
1. Use write_char_pbp - used if GLCD_USE_BLOCK_WRITE = FALSE, or if
GLCD_USE_BLOCK_WRITE is not defined. This is the most basic (slow),
anyone can use it and will be able to print all font types. The only
requirement is a write_pixel procedure. Anyone that creates a new glcd
library will have fonts working in no time :)
2. Use a custom write_char procedure (like you did in nokia lib)
3. Use write_char_block - used if GLCD_USE_BLOCK_WRITE = TRUE, A very
efficient way to write characters, but can only use the font type that
is most efficient for the glcd. This has these requirements:

All of the below can be defined in glcd device library for option 3:
--    glcd_block_address(x1,y1,x2,y2) - set start x,y and end x,y
address
--    glcd_block_write_color(color) - write a color to each pixel in
order
--    const GLCD_BLOCK_WRITE_TYPE = FONT_TOP_LEFT_HORIZONTAL - most
efficient font type for glcd.

It should not be too difficult for you to try option 3 since you have
a cache. Option 3 also allows fast printing of images. See
glcd_draw_image(), you can add support for drawing 1 bit color images.

Maybe FONT_TOP_LEFT_HORIZONTAL should be renamed to
GLCD_BLOCK_TOP_LEFT_HORIZONTAL.

You should also add your name to the glcd_common library.

Matt.

-- 
You received this message because you are subscribed to the Google Groups 
"jallib" group.
To post to this group, send email to [email protected].
To unsubscribe from this group, send email to 
[email protected].
For more options, visit this group at 
http://groups.google.com/group/jallib?hl=en.

Reply via email to