[ 
https://issues.apache.org/jira/browse/LUCENE-1614?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12714399#action_12714399
 ] 

Shai Erera commented on LUCENE-1614:
------------------------------------

I don't like that code also. But if we allow to return any value, except -1 or 
NO_MORE_DOCS before the iteration started, someone will have very hard time 
trying to write such code (to determine if the iterator has started).

The current contract already specifies what this method should return when 
nextDoc or advance were not called. We just need to make it more explicit:
* Return -1 if the iteration did not start, and there are documents to return
* Return NO_MORE_DOCS if there are no more docs to return (whether the 
iteration started or not).
* Return the doc ID on any other case..

Note that I also wrote that this method should not throw any exception, but I 
think of relaxing that either, and say "it is better if the implementation does 
not throw any exception in case there are no more documents to return". The 
reason is, we cannot force "don't throw exception" in the code ... What do you 
think?

I will update the patch if you agree to these changes.

> Add next() and skipTo() variants to DocIdSetIterator that return the current 
> doc, instead of boolean
> ----------------------------------------------------------------------------------------------------
>
>                 Key: LUCENE-1614
>                 URL: https://issues.apache.org/jira/browse/LUCENE-1614
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: Search
>            Reporter: Shai Erera
>             Fix For: 2.9
>
>         Attachments: LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch, 
> LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch, LUCENE-1614.patch
>
>
> See 
> http://www.nabble.com/Another-possible-optimization---now-in-DocIdSetIterator-p23223319.html
>  for the full discussion. The basic idea is to add variants to those two 
> methods that return the current doc they are at, to save successive calls to 
> doc(). If there are no more docs, return -1. A summary of what was discussed 
> so far:
> # Deprecate those two methods.
> # Add nextDoc() and skipToDoc(int) that return doc, with default impl in DISI 
> (calls next() and skipTo() respectively, and will be changed to abstract in 
> 3.0).
> #* I actually would like to propose an alternative to the names: advance() 
> and advance(int) - the first advances by one, the second advances to target.
> # Wherever these are used, do something like '(doc = advance()) >= 0' instead 
> of comparing to -1 for improved performance.
> I will post a patch shortly

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: java-dev-h...@lucene.apache.org

Reply via email to